11 dic. 2015

Poner la fecha en otra lengua en libreOffice Calc

Quiero formatear una fecha en valenciano en una hoja de cálculo de Calc, independientemente de la configuración de idioma del usuario que la abre.
=TEXTO(A1;"[$-803]d mmmm \d\e aaaa")
  • A1 es la celda con la fecha
  • [$-803] es el ID local (Local ID, o LCID) del valenciano. Es posible que no funcione en versiones viejas de Calc. En ese caso podríamos probar con [$-403], el LCID del catalán.
Por ejemplo, si A1=3/01/2015, el resultado de la fórmula será: "3 gener de 2015".
Si queremos que aparezca la preposición "de" delante del mes, la cosa se complica un poco porque hay que controlar si éste comienza por vocal para apostrofar. En este caso la fórmula quedaría así:
= DÍA(A1) & SI(O(MES(A1)=4;MES(A1)=8;MES(A1)=10);" d'";" de ") & TEXTO(A1;"[$-803]mmmm \d\e yyyy")
Lista de LCID de Windows

Error 0x000006D9 al compartir una impresora en Windows 7

Al intentar compartir una impresora en Windows 7 me sale el error:
Windows no puede compartir la impresora. La operación no se pudo completar (Error 0x000006D9)
El error ocurre al no estar activado el Firewall de Windows (?), así que lo activaremos temporalmente. Pasos a seguir:
  1. Ejecutar services.msc
  2. Seleccionar el servicio de Firewall de Windows.
  3. Cambiar el tipo de inicio a Manual y Aplicar.
  4. Iniciar el servicio.
  5. Compartir la impresora.
  6. Detener el servicio.
  7. Cambiar el tipo de inicio del servicio a lo que estuviera inicialmente, posiblemente fuera Deshabilitado.